SharePoint 2010--Master Page Won't Update After Re-Deploying wsp

by dcurtis 11/2/2011 12:33:00 PM

I ran across an issue today that has bugged me for while, but I hadn't bothered to look for a solution until today.

My client has some custom master pages that are deployed via a feature as part of the package.  I've noticed for quite awhile that whenever we made changes to the master pages in Visual Studio, the changes didn't necessarily get deployed when we re-deployed the package so we would go into SharePoint Designer and make the changes manually.  I tried a few different things to resolve this, but nothing would work.  I finally found a post here that seemed to suggest something that might work--it essentially says to re-activate the feature to see the changes reflected.  DOH!  Sure enough, once I did that, I could see all of the changes.  Makes total sense--we are deploying the master page and page layouts as a feature, so they aren't updated until you re-activate the feature--wish I'd thought of that before Cry.

Currently rated 3.0 by 5 people

  • Currently 3/5 Stars.
  • 1
  • 2
  • 3
  • 4
  • 5

Tags:

SharePoint 2010

Related posts

Comments

Powered by BlogEngine.NET 1.3.0.0
Theme by Mads Kristensen

About the author

Derek Curtis Derek Curtis
President, Plaid Pony Technology Solutions LLC

E-mail me Send mail

Calendar

<<  November 2017  >>
MoTuWeThFrSaSu
303112345
6789101112
13141516171819
20212223242526
27282930123
45678910

View posts in large calendar

Pages

    Recent comments

    Authors

    Disclaimer

    The opinions expressed herein are my own personal opinions and do not represent my employer's view in anyway.

    © Copyright 2017

    Sign in